Cisco command references for Cisco 2960, 3550, 3750, 4506

Enter the enable command to access privileged EXEC mode:

Switch> enable


Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Enable Telnet

Switch(config-if)#Line vty 5 15

Switch(config-if)#password yourpassword

Switch(config-if)#transport input telnet



Switch(config-if)#snmp-server community public RO

add NTP

Switch(config-if)#ntp peer IP-address

add name server

Switch(config-if)#ip name-server IP-address

Switch(config-if)#ip domain-name domain name

Create new VLAN

Switch(config-if)#vlan vlan-id

Switch(config-if)#name vlan-name

Switch(config-if)#interface vlan vlan-id

Switch(config-if)#description vlan-name

Adding IP helper

Switch(config-if)#interface vlan vlan-id

Switch(config-if)#ip helper-address IP-address

Adding sppaning-tree

Switch(config-if)#interface eth0/port-number

Switch(config-if)#spanning-tree portfast

delete VLAN

Switch#VLAN database

Switch(config-if)#no vlan vlan-id

Access List

This example shows how to configure an extended IP ACL that allows only TCP traffic to the destination IP address with a TCP port number of 25 and how to apply it to an interface: 
 Switch(config)#access-list 102 permit tcp any host eq 25  

Switch(config)#interface fastethernet0/8



Switch(config-if)#ip access-group 102 in 


This is an example of an extended ACL that allows TCP traffic only from two specified networks. The wildcard bits apply to the host portions of the network addresses. Any host with a source address that does not match the ACL statements is denied.

access-list 104 permit tcp any

access-list 104 permit tcp any

Switch(config-if)#access-list 101 deny   ip

Switch(Config-if)#access-list 101 permit ip any any

IP Routing

ip default-gateway x.x.x.1
ip route x.x.x.1
ip route x.x.x.x  x.x.x.1
ip route x.x.x.0 VlanX
ip route x.x.x.0 VlanX

VLAN IP setup

 interface VlanX
 description Server VLAN
 ip address x.x.x.1

ip helper-address x.x.x.x

view config

Switch#show vlan brief

Switch#show vlan

Switch#show running-config

Switch#show startup-config

write config permanently


How to Backup Startup-Configuration?



switch#copy startup-config tftp:

Address or name of remote host []?

Destination filename [dhaka-confg]?


1558 bytes copied in 0.248 secs


How to Backup IOS?


switch#copy flash: tftp:

Source filename []? flash:c2500-jk8os-l.122-1d.bin

Address or name of remote host []?

Destination filename [c2500-jk8os-l.122-1d.bin]?

How to Restore Startup-Configuration?


switch#copy tftp: startup-config

Address or name of remote host []?

Source filename []? switch-confg

Destination filename [startup-config]?

How to Erase the NVRAM?


switch#write erase

Erasing the nvram filesystem will remove all files! Continue? [confirm]


Erase of nvram: complete



Proceed with reload? [confirm]

About Raihan Al-Beruni

My Name is Raihan Al-Beruni. I am working as an Infrastructure Architect in Data Center Technologies in Perth, Western Australia. I have been working on Microsoft technologies for more than 15 years. Other than Microsoft technologies I also work on Citrix validated solution and VMware data center virtualization technologies. I have a Masters degree in E-Commerce. I am certified in Microsoft, VMware, ITIL and EMC. My core focus is on cloud technologies. In my blog I share my knowledge and experience to enrich information technology community as a whole. I hope my contribution through this blog will help someone who wants more information on data center technologies.
Gallery | This entry was posted in Windows Server and tagged , , , . Bookmark the permalink.

6 Responses to Cisco command references for Cisco 2960, 3550, 3750, 4506

  1. Sayednooragha says:

    Hi Dear Rehain!
    i have the Cisco Airnet 1140 series.
    can u tell me plz how to configure it becuase i tried to much to configured it but i could’nt i type any IP in IE bt there i could nt get into the configuration window.


  2. Sayednooragha says:

    Hi dear Rehain wish ur fine and doing well!
    I have problem with TMG also the issues is that i cannot install TMG 2010 on DC
    is there any sol…to how to install it on DC.
    I’v installed DC, DHCP and DNS.


  3. Imran Ali says:

    Very usefull documents for it professionals


  4. sunil kumar peekay says:

    how I can enable sfp transceiver in cisco switch 2960g


Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s