How to configure SMB 3.0 Multichannel in Windows Server 2012 Step by Step

SMB Multichannel

The SMB protocol follows the client-server model; the protocol level is negotiated by the client request and server response when establishing a new SMB connection. Windows Server 2012 introduces a feature called SMB 3.0 Multichannel. Multichannel provides link aggregation and fault tolerance.

SMB 3.0 introduces multipath I/O (MPIO) where multiple TCP connections can be established with given SMB session. Benefits include increase bandwidth, enable transparent network interface failover and load balancing per session.

SMB Encryption

Open following registry key

HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

  • If value of EncryptData DWORD is set to 0 then communication between SMB client and server is encrypted
  • If value of RejectUnencryptedAccess DWORD is set to 1 then communication between SMB client and server is rejected.

SMB Multichannel Requirement:

  • At least two computers that run on Windows Server 2012 R2, Windows Server 2012, or Windows 8 operating systems. No additional features have to be installed—SMB Multichannel is enabled by default.
  • Multiple network adapters in all hosts
  • One or more network adapters that support Receive Side Scaling (RSS)
  • One of more network adapters that are configured by using NIC Teaming
  • One or more network adapters that support remote direct memory access (RDMA)
  • Both NICs must be in different subnets
  • Enable NICs for client access
  • Dedicated subnets SMB storage
  • Dedicated Storage VLAN depending on if/how you do converged fabrics
  • VNX File OE version 7.1.65 and later or SMB 3.0 compliant storage
  • Port Channel Group configured in Cisco switch

TCP/IP session without Multichannel Session

  • No Automatic failover or Automatic failover if NICs are teamed
  • No Automatic failover if RDMA capability is not used
  • Only one NIC engaged
  • Only one CPU engaged
  • Can not use combined NIC bandwidth

TCP/IP session without Multichannel Session

  • Automatic failover or faster automatic failover if NICs are teamed
  • Automatic failover if RDMA capability is used. Multiple RDMA connection
  • All NICs engaged
  • CPU work load shared across all CPU cores
  • Combine NIC bandwidth

Which one to use, RDMA or RSS?

If you are looking fault tolerance and throughput then obvious choice is NIC teaming with RSS.

Adding a SMB Share in VNX Storage

  1. Create a network. Go to Settings -> Network -> Settings for File, Setup your network information
  2. Go to Storage -> Storage Configuration -> File Systems to create storage. Setup your storage configuration
  3. Go to CIFS Servers tab and create your Server configuration.
  4. Go back to your CIFS Share configuration and assign your CIFS Server as allowed and allow SMB protocol.
  5. Connect your CIFS Share with \\CIFSServer\CIFSShare and your new administrator password.

Adding a port channel group in Switch

Configuration of Cisco Switch with 2 network ports (If you have Cisco)

Switch#conf t
Switch(config)#Int PORT (a.e. Gi3/1)
Switch(config)#switchport mode access
Switch(config)#spanning-tree portfast
Switch(config)#channel-group <40> mode active
Switch(config)#Int port (a.e. Gi3/1)
Switch(config)#switchport mode access
Switch(config)#spanning-tree portfast
Switch(config)#channel-group <40> mode active

Configuration of HP Procurve with 2 network ports (If you have HP)

PROCURVE#conf ter
PROCURVE# trunk PORT1-PORT2 (a.e. C1/C2) Trk<ID> (a.e. Trk99) LACP
PROCURVE# vlan <VLANID>
PROCURVE# untagged Trk<ID> (a.e. Trk99)
PROCURVE# show lacp
PROCURVE# show log lacp

Adding SMB 3.0 Share in Hyper-v

  1. From Server Manager, click Tools and then click Hyper-V Manager
  2. Click Hyper-v Settings, Click Virtual Hard Disk, Type UNC path of SMB 3.0. Click Virtual Machine, Type UNC path of SMB 3.0
  3. Click Ok.
  4. Open PowerShell Prompt, Enable Multichannel using the following cmdlets.
  5. Configure SMB Multichannel using Windows PowerShell

Get-SmbClientConfiguration | Select EnableMultichannel

Get-SmbServerConfiguration | Select EnableMultichannel

    6. Enable Multichannel

Set-SmbServerConfiguration -EnableMultiChannel $true

Set-SmbClientConfiguration -EnableMultiChannel $true

   7. Verify Multichannel

Get-SmbConnection

Get-SmbMultichannelConnection

How to backup and restore Cisco switch/router config in easy steps

Backup Cisco Router or Switch in a Text File

Step1: create a text file in C:\ drive or your preferred drive and name it like switch-config.txt  or your preferred name.

Step2: open command prompt and type as follows

Telnet –F c:\switch-config.txt IP-Address-of-switch

switch>Enable

provide privilege password

#Terminal Length 0

#Show run

#Show start

#show vlan brief

Now you can exit from telnet and go to c:\ drive and open switch-config.txt to view switch/router config.

Backing Up Configuration in TFTP Server

[Router name] #copy run tftp

Address or name of remote host []? X.X.X.X (the ip address of TFTP server)

Destination filename [routername-confg]? /CiscoBackup/router1.cfg (Total path and hit enter)

Restoring a configuration from TFTP Server

[router name]# show run

[router name]#copy tftp run

Address or name of remote host []?X.X.X.X (the ip address of TFTP server)

Source filename[]?/CiscoBackup/router1.cfg (Total path and hit enter)

[router name]#show run

[router name]#show interfaces

[router name]#copy run start

Cisco core 4506: Sample config

If you are thinking, you could see sample core switch config and modify according to your need. Here, I would like to share a sample config…

Building configuration…
Current configuration : 6599 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service compress-config
!
hostname core-4506
!
enable secret 5 $1$XF/2$bxyvsqDf1LZ6n8TFyhwmg1
enable password 7 0518090035445D08000005
!
clock timezone WST 8
ip subnet-zero
no ip domain-lookup
ip domain-name YourDomainName
ip name-server xx.xx.xx.xx
ip name-server xx.xx.xx.xx
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree vlan 1-3 priority 8192
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
more interface…………

interface GigabitEthernet3/1
!
interface GigabitEthernet3/2
!
interface GigabitEthernet4/1
!
more interface……………..
interface GigabitEthernet4/6
!
interface GigabitEthernet5/1
!
interface GigabitEthernet6/2
switchport access vlan 5
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet6/4
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet6/5
switchport access vlan 105
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet6/9
switchport access vlan 5
switchport mode access
spanning-tree portfast
!
more interface config………….based how many modules you have….

interface GigabitEthernet6/15
switchport access vlan 5
switchport trunk encapsulation dot1q
!
interface GigabitEthernet6/23
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet6/24
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface Vlan1
description Admin VLAN
no ip address
!
interface Vlan2
no ip address
!
interface Vlan3
description Live Internet
no ip address
!
interface Vlan5
description Server VLAN
ip address 10.143.8.2 255.255.255.128

ip helper-address 10.143.8.24
!
interface Vlan6
description iMac_iPhone
ip address 10.143.7.1 255.255.255.128
ip helper-address 10.143.8.24
!
interface Vlan7
description Printer_SRV
ip address 10.143.6.1 255.255.255.128
ip helper-address 10.143.8.24
!
interface Vlan10
description thin client
no ip address
!
interface Vlan15
description thin client
no ip address
!
interface Vlan16
description thin client Relay
no ip address
!
interface Vlan50
description Admin Network
no ip address
shutdown
!
interface Vlan100
description Special Network
ip address 10.143.12.1 255.255.252.0
ip access-group 101 in
ip helper-address 10.143.8.24
ip helper-address 10.143.8.5
!
interface Vlan105
description staff Network
ip address 10.143.10.1 255.255.254.0
ip helper-address 10.143.8.24
ip helper-address 10.143.8.5
!
interface Vlan110
no ip address
!
interface Vlan200
description Wireless Network
no ip address
!
interface Vlan201
description MacWireless Network
no ip address
shutdown
!
interface Vlan900
description DMZ
no ip address
shutdown
!
ip default-gateway 10.142.8.31
ip route 0.0.0.0 0.0.0.0 10.143.8.1
ip route 10.1.9.105 255.255.255.255 10.143.8.1
ip route 10.142.8.0 255.255.248.0 Vlan1
ip route 10.143.6.0 255.255.255.128 Vlan7
ip route 10.143.7.0 255.255.255.128 Vlan6
ip route 10.143.8.0 255.255.255.128 Vlan5
ip route 10.143.10.0 255.255.254.0 Vlan105
ip route 10.143.12.0 255.255.252.0 Vlan100
ip http server
!
!
!
access-list 101 deny   ip 10.143.12.0 0.0.3.255 10.143.8.30 0.0.0.1
access-list 101 permit ip any any
!
snmp-server community public RO
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps stpx
snmp-server enable traps port-security
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps fru-ctrl
snmp-server enable traps flash insertion removal
snmp-server enable traps syslog
snmp-server enable traps bridge
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps hsrp
snmp-server enable traps bgp
snmp-server enable traps rtr
snmp-server enable traps vlan-membership
!
!
line con 0
password 7 030752452180500
login
stopbits 1
line vty 0 4
password 7 030754522180500
login
!
ntp clock-period 17179193
ntp peer 10.142.8.1
end

Cisco command references for Cisco 2960, 3550, 3750, 4506

Enter the enable command to access privileged EXEC mode:

Switch> enable

Switch#

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Enable Telnet

Switch(config-if)#Line vty 5 15

Switch(config-if)#password yourpassword

Switch(config-if)#transport input telnet

Switch(config-if)#login

Add SNMP

Switch(config-if)#snmp-server community public RO

add NTP

Switch(config-if)#ntp peer IP-address

add name server

Switch(config-if)#ip name-server IP-address

Switch(config-if)#ip domain-name domain name

Create new VLAN

Switch(config-if)#vlan vlan-id

Switch(config-if)#name vlan-name

Switch(config-if)#interface vlan vlan-id

Switch(config-if)#description vlan-name

Adding IP helper

Switch(config-if)#interface vlan vlan-id

Switch(config-if)#ip helper-address IP-address

Adding sppaning-tree

Switch(config-if)#interface eth0/port-number

Switch(config-if)#spanning-tree portfast

delete VLAN

Switch#VLAN database

Switch(config-if)#no vlan vlan-id

Access List

This example shows how to configure an extended IP ACL that allows only TCP traffic to the destination IP address 128.88.1.2 with a TCP port number of 25 and how to apply it to an interface: 
 Switch(config)#access-list 102 permit tcp any host 128.88.1.2 eq 25  

 
 
Switch(config)#interface fastethernet0/8

 
 

 

Switch(config-if)#ip access-group 102 in 
 

 

 
 
This is an example of an extended ACL that allows TCP traffic only from two specified networks. The wildcard bits apply to the host portions of the network addresses. Any host with a source address that does not match the ACL statements is denied.

 
 
access-list 104 permit tcp 192.5.0.0 0.0.255.255 any

access-list 104 permit tcp 128.88.0.0 0.0.255.255 any

Switch(config-if)#access-list 101 deny   ip 10.143.12.0 0.0.3.255 10.143.8.30 0.0.0.1

Switch(Config-if)#access-list 101 permit ip any any

IP Routing

ip default-gateway x.x.x.1
ip route 0.0.0.0 0.0.0.0 x.x.x.1
ip route x.x.x.x 255.255.255.255  x.x.x.1
ip route x.x.x.0 255.255.248.0 VlanX
ip route x.x.x.0 255.255.255.128 VlanX

VLAN IP setup

 interface VlanX
 description Server VLAN
 ip address x.x.x.1 255.255.255.128

ip helper-address x.x.x.x

view config

Switch#show vlan brief

Switch#show vlan

Switch#show running-config

Switch#show startup-config

write config permanently

switch#wr

How to Backup Startup-Configuration?

COPY/ERASE/BACKUP NVRAM @your own risk

=====================================

switch#copy startup-config tftp:

Address or name of remote host []? 192.168.100.1

Destination filename [dhaka-confg]?

!!

1558 bytes copied in 0.248 secs

switch#

How to Backup IOS?

====================================

switch#copy flash: tftp:

Source filename []? flash:c2500-jk8os-l.122-1d.bin

Address or name of remote host []? 192.168.100.1

Destination filename [c2500-jk8os-l.122-1d.bin]?

How to Restore Startup-Configuration?

=========================================

switch#copy tftp: startup-config

Address or name of remote host []? 192.168.100.1

Source filename []? switch-confg

Destination filename [startup-config]?

How to Erase the NVRAM?

==============================

switch#write erase

Erasing the nvram filesystem will remove all files! Continue? [confirm]

[OK]

Erase of nvram: complete

switch#

switch#reload

Proceed with reload? [confirm]