Cisco core 4506: Sample config


If you are thinking, you could see sample core switch config and modify according to your need. Here, I would like to share a sample config…

Building configuration…
Current configuration : 6599 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service compress-config
!
hostname core-4506
!
enable secret 5 $1$XF/2$bxyvsqDf1LZ6n8TFyhwmg1
enable password 7 0518090035445D08000005
!
clock timezone WST 8
ip subnet-zero
no ip domain-lookup
ip domain-name YourDomainName
ip name-server xx.xx.xx.xx
ip name-server xx.xx.xx.xx
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree vlan 1-3 priority 8192
power redundancy-mode redundant
!
!
!
vlan internal allocation policy ascending
!
interface GigabitEthernet1/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/2
!
interface GigabitEthernet2/1
!
more interface…………

interface GigabitEthernet3/1
!
interface GigabitEthernet3/2
!
interface GigabitEthernet4/1
!
more interface……………..
interface GigabitEthernet4/6
!
interface GigabitEthernet5/1
!
interface GigabitEthernet6/2
switchport access vlan 5
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet6/4
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet6/5
switchport access vlan 105
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet6/9
switchport access vlan 5
switchport mode access
spanning-tree portfast
!
more interface config………….based how many modules you have….

interface GigabitEthernet6/15
switchport access vlan 5
switchport trunk encapsulation dot1q
!
interface GigabitEthernet6/23
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet6/24
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface Vlan1
description Admin VLAN
no ip address
!
interface Vlan2
no ip address
!
interface Vlan3
description Live Internet
no ip address
!
interface Vlan5
description Server VLAN
ip address 10.143.8.2 255.255.255.128

ip helper-address 10.143.8.24
!
interface Vlan6
description iMac_iPhone
ip address 10.143.7.1 255.255.255.128
ip helper-address 10.143.8.24
!
interface Vlan7
description Printer_SRV
ip address 10.143.6.1 255.255.255.128
ip helper-address 10.143.8.24
!
interface Vlan10
description thin client
no ip address
!
interface Vlan15
description thin client
no ip address
!
interface Vlan16
description thin client Relay
no ip address
!
interface Vlan50
description Admin Network
no ip address
shutdown
!
interface Vlan100
description Special Network
ip address 10.143.12.1 255.255.252.0
ip access-group 101 in
ip helper-address 10.143.8.24
ip helper-address 10.143.8.5
!
interface Vlan105
description staff Network
ip address 10.143.10.1 255.255.254.0
ip helper-address 10.143.8.24
ip helper-address 10.143.8.5
!
interface Vlan110
no ip address
!
interface Vlan200
description Wireless Network
no ip address
!
interface Vlan201
description MacWireless Network
no ip address
shutdown
!
interface Vlan900
description DMZ
no ip address
shutdown
!
ip default-gateway 10.142.8.31
ip route 0.0.0.0 0.0.0.0 10.143.8.1
ip route 10.1.9.105 255.255.255.255 10.143.8.1
ip route 10.142.8.0 255.255.248.0 Vlan1
ip route 10.143.6.0 255.255.255.128 Vlan7
ip route 10.143.7.0 255.255.255.128 Vlan6
ip route 10.143.8.0 255.255.255.128 Vlan5
ip route 10.143.10.0 255.255.254.0 Vlan105
ip route 10.143.12.0 255.255.252.0 Vlan100
ip http server
!
!
!
access-list 101 deny   ip 10.143.12.0 0.0.3.255 10.143.8.30 0.0.0.1
access-list 101 permit ip any any
!
snmp-server community public RO
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps stpx
snmp-server enable traps port-security
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps fru-ctrl
snmp-server enable traps flash insertion removal
snmp-server enable traps syslog
snmp-server enable traps bridge
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps hsrp
snmp-server enable traps bgp
snmp-server enable traps rtr
snmp-server enable traps vlan-membership
!
!
line con 0
password 7 030752452180500
login
stopbits 1
line vty 0 4
password 7 030754522180500
login
!
ntp clock-period 17179193
ntp peer 10.142.8.1
end

About Raihan Al-Beruni

My Name is Raihan Al-Beruni. I am working as an Infrastructure Architect in Data Center Technologies in Perth, Western Australia. I have been working on Microsoft technologies for more than 15 years. Other than Microsoft technologies I also work on Citrix validated solution and VMware data center virtualization technologies. I have a Masters degree in E-Commerce. I am certified in Microsoft, VMware, ITIL and EMC. My core focus is on cloud technologies. In my blog I share my knowledge and experience to enrich information technology community as a whole. I hope my contribution through this blog will help someone who wants more information on data center technologies.
Gallery | This entry was posted in Windows Server and tagged , . Bookmark the permalink.

2 Responses to Cisco core 4506: Sample config

  1. nasherul says:

    how can i change speed 100 to 1000 in gigabit Ethernet in 4506 switch ???can i change speed ??????

    Like

    • Your Cisco Core 4506 should have Gigibit ethernet port coming with it depending on what you type of model you have purchased. You have to use minimum CAT5E or CAT6 cable to get Gigabit speed. Speed is auto configured in 4506 switch. you don’t have to do anything special.

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s